Foros Domótica Doméstica

eedomus: "escenas" versus "estados"

eedomus: "escenas" versus "estados"
« en: Mayo 06, 2019, 14:22:20 pm »
Estimados colegas eedomóticos:

Estoy probando las escenas y los estados y no alcanzo a ver la utilidad de los unos frente a los otros.

Por lo que he leído en el manual de eedomus: 1) una "escena" permite crear un actuador virtual y posibilita el control de varios periféricos en una sola operación; 2) un "estado", permite crear un periférico genérico que puede servir para hacer un actuador virtual, un receptor para la API de datos, etc. La documentación añade, que un "estado" es un módulo diseñado a medida para cubrir algún uso avanzado que suele estar relacionado con el motor de reglas y que, una vez creado, permite programar casi cualquier cosa.

Me he creado unas cuantas "escenas" para probar y me funcionan bien. También me he puesto a crear un "estado" y me he quedado con la impresión de que sirve para lo mismo que una escena, aunque he visto que en el apartado de "Uso" aparecen cosas diferentes en el uno y en el otro. Estoy convencido de que hay algo (o mucho) que no he entendido, . ¿Alguien me puede explicar cuándo se debe usar una escena o un estado? Si pudiera ser con un ejemplo, mucho mejor.

Un saludo

phroc

  • *****
  • 5171
  • Belle époque
    • Ver Perfil
    • Domótica Doméstica
Re:eedomus: "escenas" versus "estados"
« Respuesta #1 en: Mayo 06, 2019, 17:44:37 pm »
Un "Estado" permite crear tanto sensores como actuadores virtuales.

Una "Escena" sólo permite crear actuadores, no sensores.

Esa es la diferencia.



 
Coming together is a beginning; keeping together is progress; working together is success - Henry Ford

http://www.domoticadomestica.com/
https://pr-domotica.es/

Re:eedomus: "escenas" versus "estados"
« Respuesta #2 en: Mayo 06, 2019, 17:50:51 pm »
Muchas gracias por tu pronta y aclaradora explicación, Philippe. Un saludo

Re:eedomus: "escenas" versus "estados"
« Respuesta #3 en: Agosto 29, 2019, 09:29:34 am »
Buenos días,
aprovecho el hilo y hago un pequeño reflote para presentar una consulta.

Tengo creados estados para establecer "ventanas de tiempo", de manera que tengo un dispositivo del tipo estado, el cual se vuelve de cerrado a abierto durante 5 minutos cuando se desencadena una acción.

El ejemplo típico es el de la doble verificación para los sensores de movimiento, si salta un sensor, el dispositivo estado cambia de cerrado a abierto durante 5 minutos, y si se vuelve a registrar un movimiento del sensor en esa ventana de tiempo,entones ya salta la alarma.

Mi consulta es, que de un tiempo a esta parte, me estan fallando un montón estos sensores/estados virtuales, en lo que se refiere a las macros. Lo que lleva años funcionando correctamente, "Abierto 5 minutos -> Cerrado", ahora se queda pillado en el estado abierto, o en otras ocasiones entra en un bucle infinito de: "Abierto -> Auto" cada 2-3 segundos.

Esto me está pasando en dos instalaciones distintas, con distintos controladores y cuentas. Me gustaría saber si a alguien más le está pasando este problema y si hay alguna solución conocida o alternativa, ya que es una funcionalidad muy útil y me está trastocando toda mi automatización.

Muchísimas gracias y un saludo

Re:eedomus: "escenas" versus "estados"
« Respuesta #4 en: Septiembre 13, 2019, 16:38:54 pm »
A nadie más le pasa?¿


Enviado desde mi SM-G975F mediante Tapatalk


Nax

Re:eedomus: "escenas" versus "estados"
« Respuesta #5 en: Septiembre 19, 2019, 09:57:40 am »
Lamento no poder ayudarte, pero quería darte las gracias con la idea que aportas para la verificación en un sistema de alarma. Ahora mismo estoy a un paso de dejar por imposible mi sistema porque no soy capaz de configurarlo. O bien la preconfiguración que trae eedomus no funciona bien.
Como puedes ver este foro no es demasiado activo y desgraciadamente hay mucho desconocimiento con respecto a eedomus; de hecho ya lo he comentado alguna vez pero yo no lo calificaría de domotica DIY.
Quizas estoy acostumbrado a otros foros donde he participado (mi situación ahora me lo impide) y todo el mundo aportamos lo poco que sabemos. Pero el gran problema es que ni siquiera hay un soporte tecnico, donde poder contratar un servicio (como hace Zipato), para, previo pago, poder solucionar cualquier duda o incluso encargar que te configuren el equipo a tu gusto.
Lo dicho, siento no poder ayudarte, pero no queria dejar de agradecerte tu aporte.

Re:eedomus: "escenas" versus "estados"
« Respuesta #6 en: Septiembre 19, 2019, 10:14:28 am »
Lamento no poder ayudarte, pero quería darte las gracias con la idea que aportas para la verificación en un sistema de alarma. Ahora mismo estoy a un paso de dejar por imposible mi sistema porque no soy capaz de configurarlo. O bien la preconfiguración que trae eedomus no funciona bien.
Como puedes ver este foro no es demasiado activo y desgraciadamente hay mucho desconocimiento con respecto a eedomus; de hecho ya lo he comentado alguna vez pero yo no lo calificaría de domotica DIY.
Quizas estoy acostumbrado a otros foros donde he participado (mi situación ahora me lo impide) y todo el mundo aportamos lo poco que sabemos. Pero el gran problema es que ni siquiera hay un soporte tecnico, donde poder contratar un servicio (como hace Zipato), para, previo pago, poder solucionar cualquier duda o incluso encargar que te configuren el equipo a tu gusto.
Lo dicho, siento no poder ayudarte, pero no queria dejar de agradecerte tu aporte.
Que problema tienes dado por imposible?¿, yo tengo la alarma configurada ya hace un par de años y ningún problema.

Y bien fiable además.

Saludos

Enviado desde mi SM-G975F mediante Tapatalk


Nax

Re:eedomus: "escenas" versus "estados"
« Respuesta #7 en: Septiembre 19, 2019, 12:28:00 pm »
Empiezo por el principio... Tengo un teclado zipato con 7 tags mas la clave manual que funciona perfectamente.
Primero quise crear yo mis reglas para poder ajustar la alarma a mis necesidades. Pero con las Macros para el retardo de la activación, para que me diera tiempo a salir, la lié mucho y entraba en bucle. La csa iba así:
Si el teclado ahora se vuelve activado por (nombre del familiar)
Activamacro retardo:
     Espera 0 segundos y desactiva
     Espera 10 segundos y activa

Y claro, al activar volvia a esperar 0 segundos y desactivaba y a los 10 activaba y así hasta que el sistema la bloqueaba por seguridad. Intente introducir [interrumpir macro] pero ni caso.

Resignado a mi falta de conocimiento, opté por la opción preconfigurada "vigilancia de intrusos". Sustituyo la sirena por una lampara para que no me maten los vecinos e ir haciendo pruebas y pasan cosas raras: Cuando entro en casa y desactivo mediante el teclado, cuando pasan los 30 segundos de margen, aun estando desactivada la alarma, se enciende la lampara igual. Si la hago saltar quedandome dentro, luego al desactivar la alarma con el tag la lampara no se apaga (supongo que podria solucionarlo con una regla) otra locura era que una vez saltaba la alarma la lampara se quedaba encendida pero la alarma se desactivaba sola... Con este panorama a ver quien es el guapo que cambia la lampara por una sirena y se va de vacaciones...

Total, hace un rato y por enésima vez, he vuelvo a borrarlo todo y aquí estoy intentándolo de nuevo...
Una cosa si te digo, como consiga hacer que esto funcione voy a hacer un tuto para zoquetes como yo, que hasta los niños van a ser capaces de configurar la santa alarma con eedomus, porque mira que hay entradas en este foro del mismo problema con la alarma y ninguna solución...

Re:eedomus: "escenas" versus "estados"
« Respuesta #8 en: Septiembre 19, 2019, 13:10:48 pm »
Empiezo por el principio... Tengo un teclado zipato con 7 tags mas la clave manual que funciona perfectamente.
Primero quise crear yo mis reglas para poder ajustar la alarma a mis necesidades. Pero con las Macros para el retardo de la activación, para que me diera tiempo a salir, la lié mucho y entraba en bucle. La csa iba así:
Si el teclado ahora se vuelve activado por (nombre del familiar)
Activamacro retardo:
     Espera 0 segundos y desactiva
     Espera 10 segundos y activa

Y claro, al activar volvia a esperar 0 segundos y desactivaba y a los 10 activaba y así hasta que el sistema la bloqueaba por seguridad. Intente introducir [interrumpir macro] pero ni caso.

Resignado a mi falta de conocimiento, opté por la opción preconfigurada "vigilancia de intrusos". Sustituyo la sirena por una lampara para que no me maten los vecinos e ir haciendo pruebas y pasan cosas raras: Cuando entro en casa y desactivo mediante el teclado, cuando pasan los 30 segundos de margen, aun estando desactivada la alarma, se enciende la lampara igual. Si la hago saltar quedandome dentro, luego al desactivar la alarma con el tag la lampara no se apaga (supongo que podria solucionarlo con una regla) otra locura era que una vez saltaba la alarma la lampara se quedaba encendida pero la alarma se desactivaba sola... Con este panorama a ver quien es el guapo que cambia la lampara por una sirena y se va de vacaciones...

Total, hace un rato y por enésima vez, he vuelvo a borrarlo todo y aquí estoy intentándolo de nuevo...
Una cosa si te digo, como consiga hacer que esto funcione voy a hacer un tuto para zoquetes como yo, que hasta los niños van a ser capaces de configurar la santa alarma con eedomus, porque mira que hay entradas en este foro del mismo problema con la alarma y ninguna solución...

Lo entiendo y parece bastante fácil la funcionalidad que pides. Desconozco los dispositivos virtuales que usas, así que te pongo mis reglas y lo mismo te sirven de inspiración.

Tengo un sensor virtual que es los estados de la alarma, y en valores las distintas opciones: conectada, desconectada, sólo exterior, sólo PB, etc. (Ver imagen adjunta). Tengo una regla creada que si este sensor virtual cambia de estado a desconectada me mande un mensaje pushover indicandome "alarma desconectada", y si cambia a diferente de desconectada, me mande un mensaje de "alarma conectada". Así se cuando se activa y desactiva la alarma.

Sobre ese sensor virtual tengo las macros hechas, en función de si quiero algún tipo de retardo en la conexión. (Ver imagen adjunta)

Y ahora te adjunto también un ejemplo de regla, para cuando la alarma está en estado "conectado"
y otro ejemplo, que creo te servirá para el tema de retardos, que es la regla que uso para que se autoactive si me voy de casa y se nos olvida a mi mujer o a mi ponerla. Esta regla hace uso de la macro que también te he adjuntado.

Decirte que esto me está funcionando perfectamente y sin ningún tipo de fallo.
Espero que te sirva de ayuda, un saludo.


Re:eedomus: "escenas" versus "estados"
« Respuesta #9 en: Septiembre 19, 2019, 13:11:28 pm »
Foto 2

Re:eedomus: "escenas" versus "estados"
« Respuesta #10 en: Septiembre 19, 2019, 13:11:57 pm »
Foto 3 y 4

Nax

Re:eedomus: "escenas" versus "estados"
« Respuesta #11 en: Septiembre 19, 2019, 14:33:33 pm »
MUCHAS GRACIAS @adrian335d!!!
Esto me va a servir de gran ayuda para poder tirar para adelante esta historia que ya se me hace pesada...
Empezaré con una alarma muy básica y luego le iré haciendo como tú e ir añadiendo diferentes tipos.

Acabo de empezar con la programación preestablecida y hay una cosa que no puedo hacer: interrumpir la macro de armado. La de disparar la alarma si la puedo interrumpir, pero la de armar el sistema no. La tengo a 1 minuto, de manera que si se me olvida algo y vuelvo a entrar, solo puedo pararla desde el móvil, no con los tags o si se dispara, como tarda un minuto en rearmase, durante ese tiempo tiene que estar sonando la sirena para poder desactivarla.
Sabes como poder interrumpirla?.

DonQui

  • **
  • 86
  • Lo único que se, es que no se nada.
    • Ver Perfil
Re:eedomus: "escenas" versus "estados"
« Respuesta #12 en: Octubre 29, 2019, 22:49:30 pm »
A nadie más le pasa?¿


Enviado desde mi SM-G975F mediante Tapatalk

Más vale tarde.... y por confirmar tus sospechas...
Yo también he notado que las macros no van todo lo bien que debieran...

A mi me pasaba con una macro que abría el riego de las plantas y lo cerraba a los 4 minutos (pero había veces que no lo hacía, quedándose abierto horas, horas y horas; pobres plantas....). Al principio lo achaqué a falta de cobertura y que la señal de "cerrar" no le llegaba por cualquier motivo (es una electroválvula china, así que no descartaba que fuera mala).
Pero al final, en mi caso, lo sustituí por una "programación" y no me ha vuelto a fallar, donde especifico la hora de apertura y la hora de cierre por separado, por lo que se confirma que no es problema de la señal z-wave, y por tanto, diría que es del funcionamiento propio de la macro.